Sveki,

Informuojame, kad jūs jau galite išbandyti PHP 7, prieš pasirodant galutinei versijai.

PHP 7 Release Candidate 5 versija jau prieinama Linux svetainių talpinimo planuose (PHPinfo: http://fpm7.0-check.cluster015.ovh.net/phpinfo.php).

SVARBU

PHP 7 Release Candidate 5 versija dar nėra stabili. Todėl nerekomenduojame jos naudoti veikiančiose svetainėse.

Naudojant šią išankstinę versiją, gedimo atveju, OVH negalės jums padėti.
Pasirodžius galutinei versijai, ji bus įdiegta OVH (daugiau informacijos: https://wiki.php.net/todo/php70#timetable)

PHP 7?

Praėjus 20 metų po PHP sukūrimo sulaukėme 7 versijos. Jūsų OVH talpinamos svetainės iš tiesų taps spartesnės ir stabilesnės. Jeigu dar neskaitėte OVH straipsnių apie šią naująją versiją, spauskite nuorodas:

https://www.ovh.lt/naujienos/straips...hp-dar-nedingo
https://www.ovh.lt/naujienos/straips...aikas-migruoti

Norėdami patikrinti, ar jūsų svetainė yra suderinama, skaitykite oficialų PHP migravimo gidą: http://php.net/manual/fr/migration70.php.

OVH gidas: https://www.ovh.lt/g1758.migravimas_...s_php_versijas

Nebijokite, perėjimas nuo PHP5 prie PHP7 yra daug lengvesnis nei migravimas iš PHP4 į PHP5.

Kaip patikrinti PHP7 RC5?

Norite išbandyti PHP7 RC5? Tai paprasta! Jūs turite:
- turėti Linux svetainių talpinimo paslaugą (planą Asmeninis, Pro arba Performance)
- faile .OVHCONFIG pakeisti aplinkos parametrą į app.engine.version=7.0

Jei nežinote, kaip tai atlikti, skaitykite šį gidą: https://www.ovh.lt/g1207.php_konfiguravimas

Pasirodžius stabiliai PHP 7 versijai (jau greitai), jūs galėsite pakeisti PHP versiją į 7-ąją tiesiai OVH tvarkytuveV6.


SUDERINAMUMAS

PHP 7 versija yra plėtojama, todėl dar ne viskas suderinama. Pavyzdžiui, prisijungimo prie Memcache modulis nėra prieinamas.

Mes išbandėme pagrindines TVS ir svetainių kūrimo framework'us.

Rezultatai 2015-10-27:

Suderinamumas:
Wordpress: suderinama nuo 4.3 versijos;
Symfony: palaikomos visos šiuo metu suderinamos versijos: 2.3, 2.6, 2.7 ir pasirodysianti 3.0;
Zend framework: suderinama nuo 2.4 versijos (dabartinė yra 2.5);
Laravel: dabartinė 5 versija yra suderinama.

Dar nėra suderinama (tačiau planuojama):
Prestashop: artimiausiu metu pasirodysianti 1.6.1.2 dar nepalaiko (dabar release candidate);
Joomla: dar nesuderinama, tačiau planuojama, kad artimiausia 3.5 versija bus suderinama;
Drupal: dar nesuderinama, tačiau naujausia Drupal 8.0 bus suderinama (dabar release candidate).


BANDYMŲ REZULTATAI
Priėjome prie įdomiausios dalies. Iš karto pranešame, kad rezultatai puikūs.

Mūsų bandymai buvo atlikti naudojant OVH talpinimo paslaugą, su įjungtu FPM moduliu (nuo PHP5.4).

PHP bandymai:
Bandymai atlikti naudojant http://php-benchmark-script.com/.
https://www.ovh.com/fr/images/news/p...-benchmark.png

PHP 4.4 => 15,60s
PHP 5.2 => 6,89s
PHP 5.3 => 6,06s
PHP 5.4 => 4,85s
PHP 5.5 => 4,28s
PHP 5.6 => 4,20s
PHP 7.0 => 1,35s

Prestashop:
Atlikta matuojant pagrindinio puslapio įkrovos laiką
https://www.ovh.com/fr/images/news/p...Prestashop.png

PHP 5.4 => 0,708s
PHP 5.5 => 0,691s
PHP 5.6 => 0,676s
PHP 7.0 => 0,595s

Wordpress:
Atlikta matuojant pagrindinio puslapio įkrovos laiką
https://www.ovh.com/fr/images/news/p...-Wordpress.png

PHP 5.4 => 0,311s
PHP 5.5 => 0,305s
PHP 5.6 => 0,301s
PHP 7.0 => 0,270s

==> Lauksime jūsų komentarų apie PHP 7!